Discussion:
create_task preferences problem
(too old to reply)
Jake Hoffer
2018-05-04 21:05:49 UTC
Permalink
Hello OpenVAS community,

I'm having a problem when trying to set a preference while creating a task.
Here is my command:

omp --xml='<create_task><name>scan-1064</name><config
id="708f25c4-7489-11df-8094-002264764cea"/><target
id="19c80a22-7a24-4b35-a4ec-b23490230db2"/><preferences><preference><scanner_name>Ping
Host[checkbox]:Mark unrechable Hosts as dead (not
scanning)</scanner_name><value>no</value></preference></preferences></create_task>'



Here is the response I receive:

<create_task_response id="b6cef6fd-b7b3-4c01-bc0d-54e3e7d114b9"
status_text="OK, resource created" status="201"></create_task_response>



If I look in the database using sqlite3, I can see that the most recent
entry in task_preferences matches my request. However, when I actually
start the task, the scan does not honor my preference, and instead uses the
default value for the config. I know this because I have a particular host
that does not respond to pings, and the scan quits immediately unless this
preference is set to "no".

If I change the config itself, the behaviour is correct - but I'd like to
be able to use the preference override in the create_task command, rather
than having to set up an entirely new config each time I want to change
something.

Is there something I'm understanding incorrectly? Is there a different
value I need to be using in <scanner_name>? Or is it possible there is a
bug that is causing OpenVAS to ignore this preference?

Thanks!

Jake Hoffer
Lithik Systems, Inc.
Christian Fischer
2018-05-07 07:08:13 UTC
Permalink
Hi,

this mailing list is currently used for reporting problems or asking
questions about NVTs for vulnerability tests.

As your question is unrelated to those topics above i'm suggesting to
re-post this at the users mailing list to get more attraction:

http://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-discuss

As a side-note omp is deprecated and superseded by
https://github.com/greenbone/gvm-tools

Regards,
Post by Jake Hoffer
Hello OpenVAS community,
I'm having a problem when trying to set a preference while creating a task.
omp --xml='<create_task><name>scan-1064</name><config
id="708f25c4-7489-11df-8094-002264764cea"/><target
id="19c80a22-7a24-4b35-a4ec-b23490230db2"/><preferences><preference><scanner_name>Ping
Host[checkbox]:Mark unrechable Hosts as dead (not
scanning)</scanner_name><value>no</value></preference></preferences></create_task>'
<create_task_response id="b6cef6fd-b7b3-4c01-bc0d-54e3e7d114b9"
status_text="OK, resource created" status="201"></create_task_response>
If I look in the database using sqlite3, I can see that the most recent
entry in task_preferences matches my request. However, when I actually
start the task, the scan does not honor my preference, and instead uses the
default value for the config. I know this because I have a particular host
that does not respond to pings, and the scan quits immediately unless this
preference is set to "no".
If I change the config itself, the behaviour is correct - but I'd like to
be able to use the preference override in the create_task command, rather
than having to set up an entirely new config each time I want to change
something.
Is there something I'm understanding incorrectly? Is there a different
value I need to be using in <scanner_name>? Or is it possible there is a
bug that is causing OpenVAS to ignore this preference?
Thanks!
Jake Hoffer
Lithik Systems, Inc.
_______________________________________________
Openvas-plugins mailing list
https://lists.wald.intevation.org/cgi-bin/mailman/listinfo/openvas-plugins
--
Christian Fischer | PGP Key: 0x54F3CE5B76C597AD
Greenbone Networks GmbH | http://greenbone.net
Neumarkt 12, 49074 Osnabrück, Germany | AG Osnabrück, HR B 202460
Geschäftsführer: Lukas Grunwald, Dr. Jan-Oliver Wagner
Loading...